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Deskduino V2

The Edge June 2018

Summary

Participants will create an electronic display for their workplace/desk. The display uses a
programmable 8x8 LED Matrix display, an Arduino Nano and a cardboard frame made using a laser-
Cutter.

This workshop was initially developed for the Flying Arts program ArtizINNOVATE@theEdge in June
2017, then run at Woodford Folk Festival 2017/2018 and eventually run as an in-house workshop. This
latest iteration (June 2018) uses an acrylic case, suitable for either a single or multiple screens.
Cardboard Version.

Skills Introduced

e High level overview of circuit and components
e Case assembly and wiring between components
e Coding in the Arduino IDE
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https://wiki.slq.qld.gov.au/lib/exe/detail.php?id=workshops%3Aprototypes%3Adeskduino_v2%3Astart&media=workshops:prototypes:2022-23delivery-lasercutcovers:deskduino_v2:deskduino_v2_acrylic_large.jpg
https://wiki.slq.qld.gov.au/doku.php?id=workshops:prototypes:2022-23delivery-lasercutcovers:deskduino_v1:start
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Materials

Electronics

Material Quantity|Cost |Supplier

Arduino Nano v3 1 $3.40|AliExpress

MAX7219-dot-matrix-module 1 $2.10|AliExpress

Short USB Cable - USB-A to Micro USB|1 $2 [Tronixlabs

A3 3mm acrylic (clear or other) 0.1 0.75 |Acrylics Online
Total $7.50

Frame

Tools and Prepartion
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https://goo.gl/HDGZa5
https://goo.gl/ypmgEq
https://tronixlabs.com.au/cables/usb/short-usb-cable-a-plug-to-micro-usb-plug-10cm-australia/
https://www.acrylicsonline.com.au/shop-product/acrylic-sheet/a3-size-acrylic-clear-sheet-420-x-297mm
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Tools

e Computer with working USB 2.0 ports

e A working internet connection (or pre-downloaded files)
e Pen/Awl

e Ruler

Introduction to Arduino Microcontrollers

What is a micro controller?

A microcontroller (or MCU for microcontroller unit) is a small computer on a single integrated circuit.

e one or more CPUs (processor cores)

e memory

e programmable input/output peripherals

e can be mixed signal devices interacting with
o digital signals
o analog singals

Why use an MCU?

Microcontrollers are small, low powered and robust, making them perfect for embedded systems such
as:

medical devices
e remote controls
office machines
appliances
power tools

e toys
wearables!

What is Arduino?

Arduino is an open source computer hardware and software company, project, and user community "

e The hardware is based on the Amtel 8-bit AVR MCU
e The software uses the Processing IDE, with a simplified version of the C++ language
e Open source has led to the creation of a huge range of

o clones

o compatible devices
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o peripherals
e A strong community means
o “Someone, Somewhere has solved the problem”
o we can run this workshop using and adapting existing resources.

Assembly and Testing

It's time to get started!

Step One: Connecting and Testing the Arduino Nano

Download the Arduino IDE

Download the latest version of the Arduino IDE.

©.0)

Download the Arduino IDE

Windows installer
Windaws 217 file for non admin instal

ARDUIND 1.8.5 Windows app requires Win 81 or 10

The open-source Arduing Software (1DE) makes it easy to Gat I8

Wrine ©pde and upload It T2 the Doard. It rns on
Windiows, Mac 05 X, and Linwe The environment is
% writzen in [ava and bassd an Pracessing and ather open- Mac 05 X107 Lion o newer
source software
3 bits

This software can be wsed with any Arduing board
Refer 1o the Gerting Started page for Installation
instruction

Linux 4 hits
Linux are

HOURLY BUILDS LAST LIPDATE BETA BUILDS oo BETA
4 Jaruary 2008 0:34:46 CMT
Download & preview of the incoming release «.mn mhe most Daowvndioad the Bera Yersion of the Arduing IDE with
updated features and bugfices experimental features. This version should NOT be used In
productian

Select your operating system and when prompted choose “Just Download”.
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https://www.arduino.cc/en/Main/Software
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m a @ sewin =

Contribute to the Arduino Software

Consider supporting the Arduino Software by contributing to its development. (LS tax payers, please note this

cantnbution is not tax I::'."!Z:I.[[I:.'h‘.:l earn more on how your contribution will be used

SINCE MARCH 20815, THE ARDUINO IDE HAS BEEM DOWMLOADED

TIMES. (IMPRESSIVE!) WO LOMCGER JUST FOR ARDUIND
AMD CEMUINO BOARDS | HUMDREDS OF COMPAMIES AROUND THE WORLD ARE
USING THE IDE TO PROCRAM THEIR DEVICES, INCLUDIMNLG COMPATIBLES

CLOMES , AMD EVEN COUNTERFEITS. HELFP ACCELERATE ITS DEVELOPFENT

WITH A SMALL CONTRIBUTION! REMEMBER: OPEM SOURCE IS LOVE!

53 $5 $10 525 550 OTHER

JUST DOWMLOAD CONTRIBUTE & DOWMNLOAD

If you are using a genuine Arduino with the FT chipsets you won't need to download any drivers on PC
and MacOS Sierra. If you are using a knockoff Arduino with the CH340G chip you will need to
download the drivers for Mac.

Follow the instruction and install the program on your computer.

Connect Your Arduino

A red and then a green LED will light up on the Arduino, indicating that it's receiving power (for some
Arduinos this may just be a single red light)
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https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver
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Now launch Arduino IDE

QThe Edge

- sketch_feb21a | Arduino 1.8.5 - 4+ =
File Edit Sketch Tools Help

sketch_feb21a g

1.8.5 b

OQ 2e8=
| Genuino

ARDUINO

AN OFEN PROJECT WRITTEN, DEBUGGED,
' AMND SUPPORTED BY ARDUINDO.CC AND oA
THE ARDUING COMBUNITY WORLOWIDE ] |

} LEAAN MOAE ABDUT THE CONTRIBUTORS

of [ELLTECTMER «n arduine.cocfcradits

ArdunafGenuing Una an COM1
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Go to the Tools menu and change the following:

J Toos OO 1

1 Auto Format #ET
Archive Sketch
Fix Encoding & Reload
Serial Monitor {+3#EM
% Serial Plotter %L

L} i
' WIFi101 Firmware Updater

< Board: "Arduino Mano"

< Processor: "ATmega328"
' Port: "/devjcu.wchusbserial1410" >
Get Board Info

YrwY

A
Programmer: "AVRISP mkll" *

up

¢ Burn Bootloader

arintinf "BxR | F Motrix Test™

¢ Board to Arduino Nano
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s sketch_feb21a | Arduino 1.85 - +
File Edit Sketch BEGIEE Help

Auto Format Cor+T
Archive Sketch

sketch_feb2la

Fix Encoding & Reload

1 Serial Manitor Cerl+Shift+M
Serial Plotter Ctri+Shift+L
WiFi101 Firmware Updater

Board: "Arduino Nano®™ P

_ Processor: "ATmega328P" ¢ Boards Manager...
void setup() { o | Arduine AVR Board
// put your sg'°"™ ' i
Get Board Info Arduino Yin
} ) )
Programmer: "AVRISP mkIl" L Arduino/Genuina Uno
void loop() { | gurn Bootinader Arduine Duemilanove or Diecimila

77 PR TS ' T ﬁm
} Arduino/Genuing Mega or Mega 2560

Arduino Mega ADK
Arduino Leanardo
Arduino Leanardo ETH
Arduino/Genuing Micro
Arduino Esplora
Arduino Mini

Arduino Ethernet
Arduine Fio

Arduino BT

LilyPad Arduino USEB

LilyPad Arduino
Arduino Pro or Pro Mini
Arduino NG or older
Arduino Robot Control

Arduino Robot Motor F on COML

e Processor to ATmega328 or ATmega328(0ld Bootloader) if you have an older Nano
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s sketch_feb21a | Arduino 1.85 - +
File Edit Sketch QIS Help

Auto Format Cer+T

Archive Sketch

sketch_feb2la

Fix Encoding & Reload
Serial Monitor Cerl+5hift+M
Serial Plotter Cirl+5Shift+L

WiFi101 Firmware Updater

Board: "Arduine Nano” 5
) Processor: "ATmega32B8P" * | s ATmega328pP
void setup() { k

Port L ATmegal6s
Get Board Info |

/7 put your se
}

vold loop() {
S/ put your mE

Programmer: "AYRISP mkil" *

Burn Bootloader

e Port to USB/Serial (different depending on OS and Chip)
o If you are having problems finding a USB port you most likely need to download the
correct drivers.

Arduing Mana, ATmega

Once again, the exact OS (and version) as well as the chip make a big difference.

Once that is done, run “Get Board Info” in the same menu, this should bring up a small pop-up with
some information.

As long a you're not receiving an error in the console, you have successfully connected your Arduino!

Test with the Blink Example
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Another step you can take to test that everything is working is to load one of the basic example
projects and upload it to the Arduino.

* Go to File » Examples —» 01.Basic - Blink

e Click on the verify button (Check mark) and let it compile. You should get a message at the top
of the console telling you when it's done (this should take no more than a few seconds)

¢ Once this is done, without any errors, click the Upload button (Arrow)

e This will upload the instructions to the Arduino and it will say “Done Uploading” when
everything worked

e Your red LED on the Nano should now be blinking, one second on, one second off

¢ Uploading scripts to your Arduino works!

Now we are ready for the real projects

Step Two: Assembly

If you need to use the plastic bending apparatus, use 105 degrees and the settings for 3mm acrylic.
Align the horizontal line below the logo with the heating wires. make sure you are facing the plastic
the correct way, so that when the logo is displayed correctly. Also make sure to remove the protective
plastic from the acrylics before bending.

The display and Arduino rest in the frame's cavities and generally don't need to be glued. If you're
using a transparent acrylic glue will look bad and/or will create visible stains on the acrylic from the
glue fumes.

Make sure the Arduino's legs are pointing towards the back. If you've already connected your pins it is
possible to squeeze the Arduino through from the back, given the right angle.

This is how the wires need to be connected:

e SCL/CLK (System Clock) -» D10
e DIN(Data In) -» D8

e CS (Chip Select) » D9

e GND (Ground) - GND

* VCC (Voltage) - VIN

Step Four - Using the Library and Project

Now it's time to check our Arduino and LED are talking to each other.

Download and install the Library

In order to make the LED display a /ot easier to work with we'll need to install a custom version of the

Q The Edge 2025/07/18 10:22 Deskduino V2




SLQ Wiki 12/13 Deskduino V2

MaxMatrix library (found in the download section below).

¢ Go to Sketch - Include Library - Add .ZIP Library
e Just find and click the downloaded file and it will be added to your project automatically

Download and open the project

Below you will find the project files compressed into a .ZIP file.

e Extract the content wherever you'd like it and open up the wearables _matrix_ino file
e The .INO file format should be associated with Arduino and launch it automatically
e Alternatively you can open Arduino and select the File » Open option in the menu

Note: You won't be able to run this script unless you have downloaded the library above.

Upload the Project

It is time to test the project file in your desk Arduino. Upload it the same way as the blink file. Your
desk Arduino should say Free Bear Hugs.

Hacking the Code

While it's beyond the scope of this workshop to teach your how to program your Arduino - here are
some tips on:

e Changing the displayed text
e Displaying a symbol
e Changing the speed of the text scrolling

void loop()

{
// displayText(textl, 100); // Send scrolling Text

displayText(text2, 100); // Send scrolling Text
//displayCustom(smile0l, 1000);

}

Look for the void loop () section. This contains what your Arduino will do once it turns on. In this
case it will:

e ignore displayText (textl, 100); as it has been commented out with two backslashes
e displayText(text2, 100)
e ignore displayCustom(smile0@1l, 1000)

Want to change the displayed text?
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https://wiki.slq.qld.gov.au/doku.php?id=workshops:prototypes:2022-23delivery-lasercutcovers:wearables2-v3:start#arduino
https://wiki.slq.qld.gov.au/doku.php?id=workshops:prototypes:2022-23delivery-lasercutcovers:wearables2-v3:start#arduino
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e Look for text2

char text2[] = " FREE BEAR HUGS!!! "; // Scrolling Text

e and change it

char text2[] = " I Have Changed!! "; // Scrolling Text

References

e MaxMatrix Github
Downloads

Arduino

e Project Files
e MaxMatrix Library

Laser Cutter Files

These files are for cutting on The Edge Rayjet. Settings are:

Colour|Power|Speed|Description
Black (60 80 Engraving
Red |100 |[1.7 Cut lines
Blue |50 50 Bend Line

e 5x Display - Corel Draw File
e 1x Display - Corel Draw File

1)

https://en.wikipedia.org/wiki/Arduino
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https://github.com/riyas-org/max7219
https://wiki.slq.qld.gov.au/lib/exe/fetch.php?media=workshops:prototypes:2022-23delivery-lasercutcovers:wearables2-v2:201712112_badgeduino.zip
https://wiki.slq.qld.gov.au/lib/exe/fetch.php?media=workshops:prototypes:2022-23delivery-lasercutcovers:wearables2-v2:20171212_maxmatrix.zip
https://en.wikipedia.org/wiki/Arduino
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