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Workshop 02 - Operating System Install

Today we'll:

e Ensure your computer powers on

e Troubleshoot errors from Power On Self Test (POST)
e Boot to Basic Input Output System (BIOS), and

e Begin installing our Operating System (OS).

Power On

e Ensure your case is closed/fits tightly

e Connect your keyboard and mouse

e Set-up your monitor, connect the VGA cable

e Connect power cables into the monitor and case last
e Try the power button!

If correctly assembled you'll see:

e Green power and hard drive LEDs flash
e Then power LED stays on and

e Fans start up (quietly)

e BIOS screen flashes

Success!
Congratulations! Please assist others.

Failure?

e Is it fully plugged in?

» Does the power switch click? (Try removing the front panel and press it directly.)

e Check power switch connection to the motherboard. (Unplug the power lead, open case and
check the front panel power header is connected.)

e Check power cables from the PSU to the motherboard. (plugs only fit in one direction, so don't
force them.)

POST

The Power On Self Test (POST) checks your computer when it turns on. It is quick and only stops on
errors.
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If your computer turns on but doesn't pass POST, it tells you with lights and beeps.

Most errors are easily fixed.

Two Beeps
BEEPS Power LED Probable Cause
2 beeps Blinks red 2 times @ 1 Hz Processor thermal shut down. Check air flow, fan operation, and CPU heatsink

* |s the fan cable plugged in and air guide installed correctly? Are heatsink screws tight?

Three Beeps

3 beeps Blinks red 3 times @ 1 Hz Processor not installed. Install or reseat CPU.

e Is your processor is sitting in the socket firmly? Are heatsink screws firmly tightened?

Four Beeps
4 Blinks red 4 times Power failure (power supply is overloaded). Check storage devices, expansion cards and/or
beeps @ 1Hz system board (CPU power connector P3).

e |s the CPU power connector connected?

Five Beeps

5 beeps Blinks red 5 times @ 1 Hz Pre-video memory error. Incompatible or incorrectly seated RAM.

e |Is your RAM firmly clicked into place? Test RAM individually.

Six/Seven/Eight Beeps
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6 Blinks red 6 times  Pre-video graphics error. On system with integrated graphics, check/replace system board. On
beeps @ 1Hz system with graphics card, check/replace graphics card.

7 Blinks red 7 times = PCA failure. Check/replace system board.

beeps @ 1Hz

8 Blinks red 8 times  Invalid ROM (checksum error). Reflash ROM using CD or replace system board.

beeps @ 1Hz

¢ Please ask for assistance (advanced).

Nine Beeps

Obeeps  Blinks red 9 times @ 1 Hz System powers on but fails to boot. Check power supply, CPU, system board.

Check your PSU cable headers on the motherboard.

Ten Beeps

10 beeps Blinks red 10 times @ 1 Hz Bad option card

e Won't occur unless a PCl expansion card is installed. If installed, remove and reboot.
Customising BIOS

After POST your computer will continue to boot by activating the Basic Input Output System (BIOS).

e The BIOS is firmware, and works between your computer's hardware and software.
e |t's permanently attached to the hardware.
e A battery retains settings for up to 10 years.

BIOS will attempt to boot your computer and run checks. As your computer was recently
disassembled, it may request information.

It may ask to confirm hardware changes:
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4096 HB

Initializing Intel(R) Boot Agent GE v1.3.48
PXE 2.1 Build 888 (MfH 2.8)

The following configuration options were automatically updated:
Disk: 168 GB ST31683186AS
If you are running Unix, you need to configure your systen
using the Conputer Setup Utility (F18).

F1: Save Changes (F9=Boot Menu> <FiB=Setup) (F12=Network)

to set the date and time:
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4096 HB

162-Systen Options Not Set
Your systen configuration has changed since your last boot. Addition
of a hard drive, etc., or loss of pover to the Real Tine Clock has occurred.
Pressing F1 will record the new configuration. If this nessage persists,
you may need to replace the onboard battery.

PXE 2.1 Build 888 (HIN 2.8)

The following configuration options were automatically updated:
Hemory: 46896 NB
Disk: 168 GB 313168318A5
CD-RON : hp DUD A DH1GAAL
If you are running Unix, you need to configure your systen
using the Conputer Setup Utility (F18).
CHOS checksun invalid, default values loaded

F1: Save Changes

and launch operating system from the internal hard drive.
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on-Systen disk or disk error
replace and strike any key when ready

Your hard drive was wiped, so it cannot continue to boot.

System Configuration

Access 'System Configuration' so your computer can boot from USB to install our operating system. A
well-timed keystroke is required. See keys on the 'splash' screen (bottom right):
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1

<F9=Boot Menu> <F1B=Setujp

¢ F9: Choose a device to boot from.
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Press Enter to Select Boot Device, ESC to Exit

CD-RON
USH Device
Hard Drive
IBA GE Slot BBCE w1348

e F12: Force computer to boot from network card (advanced).
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Intel(R) Boot Agent GE v1.3.46
opyright (C) 1997-Z889, Intel Corporation

Intel(R) Boot Agent PXE Base Code (PXE-Z.1 build BE6)
opyright (C) 1997-Z68Y, Intel Corporation

Initializing and establishing link..._

e F10: BIOS set-up. On your next reboot, press and hold F10.
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1

<F9=Boot Menu> <F1B=Setujp

BIOS Set up

Select language:
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Dansk
Suom i
Francais
Deutsch
Italiamo
H &8
Nederlands
Norsk
Portugués
Svenska
Espaiiol

Select 'System Information' from 'File' menu.
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Heulett-Packard Setuy
FUCY Storage Security Power Advanced

I System Information

About

| Set Tine and Date
Flash System ROM

Replicated Setup

Default Setup

Apply Defaults and Exit
Ignore Changes and Exit
dave Changes and Exit

LOCAL: <F1=Help> REMOTE: F1=ESC+1, F5=ESC+5, F10=ESC+0

This displays information about the computer's components.
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Heulett-Packard Setup
Storage Security Power Advanced

Product Name

SKU Number

Processor Type
Processor Speed
Processor Stepping
Cache Size (L1/12/L3)
Hemory Size

Chamel A

Chamnel B

Integrated MAC
Systen BIOS

Chassis Serial Number
Asset Tracking Number
ME Firmuare Uersion
Management Mode

System Information

HP Compag 8100 Elite SFF PC
AYO32AU
Intel(R) Core(TH) i5 CPU
3.200 Gz
00020652 60006009
64KBx2 / 256KBx2 / 4696KEx1
40% MB DDR3/1333 Mz/Dual Chamnel
X1 2648 MB / XMi2 O MB
X3 2648 MB / XMi4 O MB
606260627461
786H1 v01.62
ALIDOZ20983
AUDGZ20983
6.0.3.11%
AT

b50 @ 3.20GHz

LOCAL: <F1=Help> REMOTE: F1=ESC+1, F5=ESC+5, F10=ESC+0

See Processor information from Workshop 017 See hardware without opening the case. Exit with any
key.
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Heulett-Packard Setup
Storage Security Power Advanced

System Information

Product Name HP Compaq 8100 Elite SFF PC

SKU Number AY032AU

Processor Type Intel(R) Core(TH) iS5 CPU 650 @ 3.20GHz
Processor Speed 3.200 GHz

Processor Stepping 00020652 66600009

Cache Size (L1/12/13)  64KBx2 / 256KBx2 / 4096KBx1
Memory Size 40% MNB DDR3/1333 Mz/Dual Chamel
Chanrel f X1 2646 MB / XMi2 © HB
Channel B X3 2048 MB / X4 © B
Integrated MAC 6C626D027401

Systen BIOS 786H1 v01.062

Chassis Serial Mumber  ALDOZ269B3

Asset Tracking Mumber  AUDOZZO9E3

ME Firmuare Uersion 6.0.3.11%

Management Mode AT

LOCAL: <F1=Help> REMOTE: F1=ESC+1, F5=ESC+5, F10=ESC+0

Set Time/Date
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Hewlett-Packard Setuy
Storage Security Power Advanced

System Information
About

[ Set Time and Date Set Time and Date
Flash System ROA

Tine (hh:mm) +12:01
Replicated Setup Date (mm/dd/yyyy)  01/21/2016

Default Setup 10=Accept, ESC=Cancel

Apply Defaults and Exit
Ignore Changes and Exit
Save Changes and Exit

LOCAL: <F1=Help> REMOTE: F1=-ESC+1, F5=ESC+5, F10=ESC+0

Select 'Storage', then 'Device Configuration'.

Recognise your hard disk and DVD drive?
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Heulett-Packard Setup
SIS Security Power Advanced

Device Configuration

Storage Options

evice Configuration

Hard Disk

PSATAB 160 GB, ST3166318AS
CD-ROM

SATA hp DDA DHIGAAL
Default Ualues

SATA Defaults

nter=Configure, ESC-Back

LOCAL: <F1=Help> REMOTE: F1=ESC+1, F5=ESC+5, F10=ESC+0

Exit and select 'Storage Options'. Enable 'Removable Media Boot' to allow booting from USB.
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Heulett-Packard Setuy
NGIETEE Security Power Advanced

Device Configuration

DPS Self-tes Storage Options

Boot Order Removable Hedia Boot PMEnable
Max eSATA Speed 1.5 Gbps
SATA Emulation 1DE

16=fccept, ESC=Cancel

LOCAL: <F1=Help> REMOTE: F1=ESC+1, F5=ESC+5, F10=ESC+0

Exit and select 'Boot Order' to see available options.
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Heulett-Packard Setup
Storage SBClEl‘itg Pover Advanced

Device Configuration
Storage Options

Boot Order

» ATAPT CD-ROM Drive
USH device
Hard Drive

Integrated SATA

Network Controller

=Disable, Enter=Drag, F10=Accept, ESC=Cancel

LOCAL: <F1=Help> REMOTE: F1=ESC+1, F5=ESC+5, F10=ESC+0

We'll boot from USB, so move USB to the top.
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Device Configuration
Storage Options

Boot Order

ATAPT CD-ROM Drive

Hard Drive
Integrated SATA

Netuwork Controller

=Disable, Enter=Drop, F10=Accept, ESC-Cancel

LOCAL: <F1=Help> REMOTE: F1=-ESC+1, F5=ESC+5, F10=ESC+0

Disable network booting if unneeded.

ﬂThe Edge 2025/07/06 11:09 Workshop 02 - Operating System Install




SLQ Wiki 21/33 Workshop 02 - Operating System Install

Device Configuration
Storage Options

Boot Order

USB device
ATAPT CD-ROM Drive
Hard Drive
Integrated SATA
P Netuork Controller Disabled

=Enable, Enter=Drag, F10=Accept, ESC=Cancel

LOCAL: <F1=Help> REMOTE: F1=-ESC+1, F5=ESC+5, F10=ESC+0

Confirm with F10 and exit Boot Order.

Return to 'File' menu. Select 'Save Changes and Exit'.
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Heulett-Packard Setuy
Storage Security Power Advanced

System Information
About

Set Time and Date —— Save Changes and Exit ———
Flash System ROM

fire you sure you want to
Replicated Setup Save Changes and Exit?

Default Setup F10=Yes, ESC=No

Apply Defaults and E-

Iguore Changes and Exit
Save Changes and Exit

LOCAL: <F1=Help> REMOTE: F1=ESC+1, F5=ESC+5, F10=ESC+0

Confirm with F10. Your computer and boot process will restart, looking for the USB.

Boot From USB

You'll be given a USB containing a Xubuntu Live System and Installer. (A Live System lets you
boot/use your computer from USB). We'll use this to install the Operating System (OS).

Insert USB and restart the computer (ctrl-alt-delete).
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If successful, it should show a desktop environment with the Install Dialogue open.

velcome

LrarTR A T eI
Bosanski ™
Catala

Celtina

Cymraeg

Dansk

Deutsch

Eesti

Espafiol

Try Xubuntu Install Kuburf}u

Esperanto
Euskara
Frangais You can try Xubuntu without making any changes to your computer, directly from this CD.

Gaeilge Or if you're ready, you can install Xubunitu alongside [or instead of) your current operating system. This

Galego shouldn’t take too long.
Hratski

Islenska "
You may wish to read the release notes.

If not, check your BIOS settings and ask for assistance.
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Install Xubuntu

Choose English, then 'Install Xubuntu'.

ywelicome
Bosanski —
Catala
Celtina
Cymraeg
Dansk
Deutsch
Eesti
Espaiial
Esperanto Try Xubuntu Install Xuburyu
Euskara
Frangais You can try Xubuntu without making any changes to your compauter, directly from this CD.
Gaeige Or if you're ready, you can install Xubunitu alongside (or instead of) your current operating system. This
Galego shouldn’t take too long,
Hruatski
Islenska
e ou may wish to read the release notes.

Keyboard Layout
Choose the correct keyboard layout. (Use 'Detect Keyboard Layout' if unsure.)
Wireless

Choose whether to connect to wireless. We'll select 'l don't want to connect to a wifi network right
now' for now.

Third Party Software

Select 'Install third-party software' (this lets us use propetary software types, such as MP3s.)
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of hasat least 6.0 GB available drive space

of isconnected to the Internet
| |

Installation Type

Select your hard disk, chose 'Erase and install', then 'Install now'.

Where are You?

Set your computer location (Brisbane), then continue.
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h.d Install +

Where are you?

Brisbane |

e wee O

Your Details
Provide your details and create a memorable password. Select 'log in automatically', then continue.

Your system will now install.

Who are you?

Your name: |u:c-o|:|a| | q‘?

Your computer's name: |mpal-virtualaux | ‘?
The name it uses when it talks to other computers.

Pick a username: | ool @?

ﬂnﬂseipmmni:|.“ |lhftpmi
Confirm your password: l." I %?

o in automatically
* Require my password to log in
|| Encrypt miy home folder

| & Back H Continue |

Complete Installation

When complete, remove your USB and restart. Enter BIOS again and change your first boot
device to internal hard disk.
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SDLW Network Setup

Let's quickly set up our local SDLW network. We'll use it to update/install software without internet.

The facilitator laptop acts as a server to store your needed files. Your facilitator will show you this.

Break Time

The Operating System
An Operating System (OS) looks after:

e Booting

Controlling peripherals

Providing a graphical user interface (GUI) and desktop environment

Managing system resources - like the Central Process Unit (CPU) and the (GPU).
Interacting with/storing files

Communicating over networks

We just installed Xubuntu - a 'flavour' of Ubuntu based on Linux, a Free and Open Source OS.

Navigating Xubuntu

Launch Xubuntu.

In the top left you can access the whisker menu, (like Windows start menu).

Here you can access pre-installed programs and desktop settings.

The File Manager

The File Manager helps us navigate your system's files and folders. Select it from the whisker menu.
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a ~File Mana B

[ - LA

DEVICES Name Size Type Date Modified -

PLACES &) Downloads 4.1 kB folder Friday

At Documents 4.1 kB folder Thursday
LA

B Desktop VirtualBox VMs 4.1 kB folder Thursday

M Riikkich Rir -
i Rubbish Bin recover 4.1 kB folder Thursday

CCC-OPAL-MEDIA ~

dchidd-1.3.4-1 4.1 kB folder 14504415

NETWORK .
iferay-6.2-6 4.1 kB folder 10/04715

Browse Metwork
i Pictures 4.1kB folder DB/04/15

CCC dokuwikivarations 4.1 kB folder 070415
scratch 4.1 kB folder 11/0315
dseprite 4.1 kB folde 1703715
apks 4.1 kB folder 10003715
er 4.1 kB folder DED315
n fal e = L

— File System . I|- .I| .i.ﬁ
PLACES -'Dlllf'gllﬂ-Iu

7> edgeuser Desktop Documents Downloads Music Pictures

= |2l B

J3 Music Public ~ Templates  Videos

““ Browse Metwork

8 items, Free space: 270.1 GIB
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Customising your Desktop

You can customise your desktop - eg, by right clicking image files (Connect your phone to drag one
over) to 'set as desktop background'. You can also change theme. In the whisker menu, select
'settings' and select 'window manager".

Q

1. Favorites - = Panel Profiles
) Recently Used | 4 Power Manager

S

== All Applications E Preferred Applications
Eﬁ, Printers

B Accessories 1 ,
Removable Drives and Media

@ PRI i Screensaver

En‘ SRS ESession and Startup
4% Graphics u Settings Editor

@ Internet -, Software Updater
[ Multimedia ﬁ Software & Updates
& Time and Date

@, Users and Groups

i Window Manager

Configure window behaviour and shortcuts

. Xfce Terminal

Select 'kokodi' - it has larger window handles for easier resizing.
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i Window Manager o x

Window Manager
Configure window behaviour and shortcuts

Style .| Keyboard Focus Advanced
Theme Title font
Default [ Droid Sans Bold 9 J
Albatross
Bluebird Title alignment
Daloa lCEntre - J
Greybird
Greybird-compact Button layout
Click and drag the buttons to change the layout
Moheli Active
Numix
v Title - || Of x
o R ==
Hidden
ndd
eHelp | XK Close

Updates

Choose 'Settings' from the whisker menu and select 'Software Updater'.
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Q
1. Favorites - w# Panel Profiles

{0 Recently Used | 4 ) Power Manager

= All Applications E Preferred Applications
Lg.l Printers

' Removable Drives and Media

ducatio S
@ . 2 ! Screensaver

Eﬂ' Ceines Session and Startup
&% Graphics ; Settings Editor
@ v ﬁ
I8 Mutimedia -
 Office
Setti h:; Users and Groups
E Window Manager
ﬁw;'ndnw Manager Tweaks
!Wnrks paces
- Xfce Terminal g

It will check for updates from the SDLW laptop.

] Software Updater - X

Checking for updates...

—s— <1

Finished

Don't worry if some updates are missing - click 'install now'.

aThe Edge 2025/07/06 11:09 Workshop 02 - Operating System Install




SLQ Wiki

32/33 Workshop 02 - Operating System Install

-

"= || Updated software is available for this
L4 computer. Do you want to install it now?

* Details of updates

Software Updater S

The computer also needs to restart to finish installing
previous updates.

61.5 MB will be downloaded.

Settings... Remind Me Later | Instgll Now ‘

L@

Enter your password - your system will update.

<

~ Details

Installing updates...

Preparing installation of linux-image-extra-3.13.0-51-generic

soltware Updater = O

Restart your computer before the next workshop.
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4 Software Updater -

Please restart the computer to begin using
your updated software.

l Settings... J l Restart Later J [Restart Now...

Workshop 03 - Productivity and System Tools
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