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101 - Intro to Premiere Pro

An Introduction to Premiere Pro.

Developed by Michelle Brown 2019, updated by Amelia Paxman 2022.

Workshop Presentation

This workshop has been created into a slide show for presentation and documentation purposes.
Please feel free to download and use the guide and files as per our CC license in the footnote.

Some pages may link to other online workshops, tutorials or guides created at The Edge, you may
require internet to connect and view links.

Admin view

Public view

What makes a good edit?

Think about your audience
Who are they?
What music do they like?

https://wiki.slq.qld.gov.au/lib/exe/detail.php?id=workshops%3Apublic%3Apremiere&media=workshops:public:20221119_jruckli_slq_theedge_102.jpg
https://statelibraryqld.sharepoint.com/:p:/t/AppliedCreativityTeam/EaQIKOz55DFFhjnyXyLhPuoBEcT4LjOfnpioUqNyyKwndA?e=5Ptrgj
https://wiki.slq.qld.gov.au/lib/exe/fetch.php?media=workshops:public:101_workshop_-_premiere_pro.pdf
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What feel are you going for?
Using images to evoke emotion

Discuss some of the favourite edits or techniques as a group so the induction can focus on some
specific areas as required.

Summary

During this session we will touch on the following.

Project set up

Source monitor
Program monitor
Timeline
Project window
Tabs for different workflows

File management
Folder structure
Keeping everything together
Importing assets
Offline files

Saving your project
Save as
The importance of regular saving
Reopening Auto-Save files

Setting up sequences
Naming sequences
Duplicating sequences
Workflow
Bin structure

Using the editing timeline

Dragging footage onto the timeline
Audio and visual components
Muting, soloing, eye icon
Zooming in and out
Time
Creating slugs

Editing tools
Drag
Trim
Razor

Footage duration
Slowing
Speeding
Reversing

Transitions
The cut
The cross dissolve/fade to black
Wipe / page tur

Effects
Effects library
Colour correction
Adding and removing other effects
Effect controls

The vertical timeline
Opacity
Overlay
Splitscreening
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Keyframing
Size
Motion
Working with still images

Text Graphics tab
Adding text

Exporting
Checking your timeline
Choosing your export location
Choosing your settings

Before getting started

This introduction covers the basics of Premiere Pro, including getting to know the user interface, but
one of the key things before you even open the program is to be organised with your assets!

Whether working off an internal or external hard drive, start every project by creating a project folder
and this folder will contain all the files related to your project. Make sure you have dedicated folders
for your raw footage, audio and for the exported drafts and final video files.

This will just make things a whole lot easier as you go.

User Interface

There are four main windows which make up the Premiere Pro workspace:

This image shows the layout of the Editing workspace without any imported media, you will see
different tabs at the top of the screen to change to different workflows.

https://wiki.slq.qld.gov.au/lib/exe/detail.php?id=workshops%3Apublic%3Apremiere&media=facilities:fablab:software:premiere_emptyui.png
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Project (bottom left): Where you import and organize your media
Source Monitor (top left): Where you view and trim your raw media
Program Monitor (top right): Where you view your timeline sequence
Timeline (bottom right): Where you create your edit

You can move these windows around and customize your workspace in Window > Workspaces

Projects and Sequences

Starting a new Project

Open the Program and you will be prompted to open or start a project.

Name your project and save it.

https://wiki.slq.qld.gov.au/lib/exe/detail.php?id=workshops%3Apublic%3Apremiere&media=facilities:fablab:software:premiere_new_project.png
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Starting a new Sequence

The sequence is where you will build your video.
File
New sequence or Command N
Select the type of camera - media type. Since Premiere Pro does a great job at automating this
process once you place your footage on the timeline, leave all this as it presents itself. Just
rename your sequence at the bottom of the window and hit OK.

Projects can contain multiple Sequences

Importing Media

2 Options;

File Import
Command i

You can import multiple media files or folders.

We have some video and audio files that we will pass around to use as assets so you can follow along
with some basic composition and editing, copy the folder 'Premiere Pro Induction Assets' on to your
desktop and pass the USB along to someone else to do the same.

Use what we just learned to import one of the video files.

https://wiki.slq.qld.gov.au/lib/exe/detail.php?id=workshops%3Apublic%3Apremiere&media=facilities:fablab:software:premiere_naming_project.png
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Editing Basics

In and Out Points

Double click on one of the video files you have imported in your project panel; this will load the clip
into your Source Monitor. Use the Mark In ({) and Mark Out (}) buttons to set the desired start and
end for this clip. The grey bar under the clip shows your clip selection. You will always be able to
tweak the length of this selection once you place your clip on the timeline, so no need to worry about
getting the perfect selection now. You can also use the I and O keys to input in and out points.

Getting a Clip Onto the Timeline

Once you’ve made your selection using in and out points, you can either drag the clip onto the
timeline (from the Project or Source Monitor windows) or using the Insert/Overwrite buttons.

Editing a Clip on the Timeline

Now that you’ve got your clip on the timeline, you can move it around and adjust its length on either
end using the Selection Tool (V). Your cursor will turn into a red arrow symbol when you position it at
the inner or outer edge of the clip, allowing you to lengthen or shorten it. Using the Razor Tool (C),
you can split your clip in two or cut out a section in the middle.

These two tools will allow you to do most of your basic editing.

Building your Sequence

This image depicts an imported video file being viewed in the Project, Source and Project Monitors
and in the Timeline window.



SLQ Wiki 8/12 101 - Intro to Premiere Pro

2025/11/06 03:16 101 - Intro to Premiere Pro

We have one video file which includes an audio track already added to our Sequence, but let's add
some more.

Find one of the backing audio tracks provided and import this into your project, find another video file
and add this so you have two lots of video footage to work with.

What we want to do is have two video tracks transition and add the music soundbed to the sequence
so we can still hear the interview, but have the music playing at a good volume underneath.

Transitions

Transitions are what happens between each bit of footage (or audio), there are many ways you can
use transitions effectively, but beware of going overboard and alienating your audience with a wrong
transition choice!

You can't really go wrong with some of the basics;

straight cut
dissolve / fade in and out (Dip to Black)

Applying transitions is as easy as dragging a transition from the Effects panel and dropping it into the
timeline at the beginning or end of a clip. To find the Effects panel if it isn't open already, choose
Window > Effects from the main menu (or press Shift+7).

Some more info on Transitions;
https://helpx.adobe.com/au/premiere-pro/how-to/apply-transitions-premiere-cc.html

https://helpx.adobe.com/au/premiere-pro/how-to/apply-transitions-premiere-cc.html
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Audio

Basic audio adjustments

Although Premiere Pro includes a full-featured Audio Track Mixer, there are times when many of these
options are not required. For example, when creating a rough cut from video and audio captured
together from DV footage, output to stereo tracks, follow these guidelines:

Start with the Master meters and volume fader in the Audio Track Mixer. If the audio is too far
below 0 dB or too high (the red clipping indicator appears), adjust the level of clips or tracks as
needed.

To temporarily silence a track, use the Mute Track button in the Audio Track Mixer or the Toggle
Track Output icon in the Timeline panel. To temporarily silence all other tracks, use the Solo
button in the Audio Track Mixer.

When making audio adjustments of any kind, determine whether the change is applied to the
entire track or to individual clips. Audio tracks and clips are edited in different ways.

Use the Show/Hide Tracks command in the Audio Track Mixer menu to display only the
information you want to see and save screen space. If you aren’t using Effects and Sends, you
can hide them by clicking the triangle at the left edge of the Audio Track Mixer.

More info here - https://helpx.adobe.com/au/premiere-pro/using/overview-audio-audio-mixer.html

Effects

You can apply one or more Standard effects to a clip by dragging effect icons from the Effects panel
to a clip in the Timeline panel. Alternatively, select the clip and double-click an effect in the Effects
panel to apply it. You can apply the same effect multiple times, using different settings each time.

You can apply Standard effects to more than one clip at a time by first selecting all the clips you want
to affect.

You can also temporarily disable any effect, which suppresses the effect without removing it, or you
can remove the effect completely.

To view and adjust effects for a selected clip, use the Effect Controls panel. Alternatively, you can
view and adjust effects for a clip in the Timeline panel by expanding its track and selecting the proper
viewing options.

By default, when you apply an effect to a clip, the effect is active for the duration of the clip. However,
you can make an effect start and stop at specific times or make the effect more or less intense by
using keyframes.

Learn more here -

https://helpx.adobe.com/au/premiere-pro/using/overview-audio-audio-mixer.html
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https://helpx.adobe.com/premiere-pro/using/applying-removing-finding-organizing-effects.html

Colour Correction

You can find the color- and luminance-adjusting effects in the Color Correction bin inside the Video
Effects bin. Although other effects also adjust color and luminance, the Color Correction effects are
designed for making fine color and luminance corrections.

You apply the Color Correction effects to a clip the same way you apply all Standard effects. The
effect properties are adjusted in the Effect Controls panel. The Color Correction effects and other color
effects are clip-based. However, you can apply them to multiple clips by nesting sequences, which is a
more advanced area that we won't really have time to go over today.

A basic guide for us to try;

Choose the clip you want to add color to on the timeline and double-click it.
Click the Effects Control tab.
Search for Fast Color Corrector, and double-click it.
When the effect loads in the Effect Controls window, it’s going to give you a ton of options.
Scroll down to the White Level and click the eyedropper icon.
Find the brightest/whitest area of your picture and click the eyedropper there.
Now go back to the Effect Controls window and go to the Black Level eyedropper.
This time you’ll be finding the darkest/blackest part of the image and click the eyedropper on it.
If you want to do more to the image, you can go to the Gray Level and use the eyedropper to
identify the neutral colors in your scene. However, you don’t always have to do this and you can
actually mess up the picture using it.
You can also adjust your Color Level Settings: you can intensify the colors or add richness to
your look. The left corresponds to the blacks in the scene, the right corresponds to the
highlights.

When correcting color, it’s useful to use the Vectorscope or waveform scopes (YC Waveform, RGB
Parade, and YCbCr Parade) to help you analyze the chroma and luminance in a clip. You can view a
scope in a separate Reference Monitor that’s ganged to the Program Monitor so that you can check
your video levels as you make adjustments.

Learn more on colour correction here -
https://helpx.adobe.com/premiere-pro/using/color-correction-adjustment.html

Exporting Video

Basic Guide to a simple export;

To export a sequence as an H.264 file (the most popular option), make sure the Timeline panel
is active and choose File > Export > Media or press Control+M (Windows) or Command+M

https://helpx.adobe.com/premiere-pro/using/applying-removing-finding-organizing-effects.html
https://helpx.adobe.com/premiere-pro/using/color-correction-adjustment.html
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(macOS).
In the Export Settings dialog box, choose Format: H.264 and Preset: Match Source – High
Bitrate.
To choose a filename and location, click the blue filename to open the Save As dialog box. Use
this to choose an export location and a name for your new file, and then click Save.
When you’re happy with your settings, click Export. The new video file will be created, ready to
share with the world.

There are many preset options for exporting, you can use the drop don menu to look through and
choose the best one for where the video project may end up being hosted.
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Health & Safety

Running this workshop at The Edge?.. You should familiarise yourself and your participants with:

DML Risk Assessment

Resources

Great set of general tutorials and tips and tricks:
https://motionarray.com/premiere-pro/adobe-premiere-pro-cc-tutorials/

Premiere Tutorials and Tips: https://helpx.adobe.com/premiere-pro/tutorials.html

Editing tips: https://vimeo.com/blog/category/video-school/tag:editing

Editing Technique: https://vimeo.com/insidetheedit

Working with and import video content from different cameras:
https://www.lynda.com/Premiere-Pro-tutorials/Starting-from-scratch-Importing-media/371692/413960-
4.html

Understanding Audio: https://www.youtube.com/watch?v=KIqV8nIjTTE

Learning the art of colour correction and grading: http://www.learncolorgrading.com/

Post haste: Is a free tool that set's up project folder stuctures:
https://www.digitalrebellion.com/posthaste/

Adobe Premiere pro forum: (issues or questions about the software)
https://forums.adobe.com/community/premiere

Green Screen footage to practice with:
http://www.hollywoodcamerawork.com/green-screen-plates.html

Art of editing: when should you cut: https://www.youtube.com/watch?v=3Q3eITC01Fg

Types of compression and video formats:
http://nofilmschool.com/2014/08/heres-what-you-need-to-know-video-compression Where to find
Creative Commons licensed footage and Music:

What is Creative Commons: http://creativecommons.org.au/

Public Domain/ Creative Commons Video Footage:
http://www.premiumbeat.com/blog/20-free-online-stock-video-sites/

Creative Commons Music: https://incompetech.com/

https://motionarray.com/premiere-pro/adobe-premiere-pro-cc-tutorials/
https://helpx.adobe.com/premiere-pro/tutorials.html
https://vimeo.com/blog/category/video-school/tag:editing
https://vimeo.com/insidetheedit
https://www.lynda.com/Premiere-Pro-tutorials/Starting-from-scratch-Importing-media/371692/413960-4.html
https://www.lynda.com/Premiere-Pro-tutorials/Starting-from-scratch-Importing-media/371692/413960-4.html
https://www.youtube.com/watch?v=KIqV8nIjTTE
http://www.learncolorgrading.com/
https://www.digitalrebellion.com/posthaste/
https://forums.adobe.com/community/premiere
http://www.hollywoodcamerawork.com/green-screen-plates.html
https://www.youtube.com/watch?v=3Q3eITC01Fg
http://nofilmschool.com/2014/08/heres-what-you-need-to-know-video-compression
http://creativecommons.org.au/
http://www.premiumbeat.com/blog/20-free-online-stock-video-sites/
https://incompetech.com/
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