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Summary

Participants will be able to create a wearable brooch with a 8x8 LED Matrix, low resolution display.
With the use of an arduino and a battery it allows for an endless possibility of customization and
innovation. Furthermore participants can continue work on their wearable tech by adding sensors for
even more interesting results.

This is the second part of the wearable workshop, find part one here. It was initially developed for the
Flying Arts program ArtizINNOVATE@theEdge in June 2017.

The workshop will cover:

Basic Electronic Skills

Basic understanding of Arduino Microcontrollers
Basic understanding of Arduino coding and the IDE
Cross-disciplinary, Arts and Technology
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Activity Summary

What's wearable technology/wearables?

e Intro to Arduino microcontrollers

e Intro to the Arduino IDE

e Download Libraries and upload them to the Arduino

e Basic / relevant electronic run down of the circuit

e Facilitator and participants put the circuit together, demonstrating step by step and then
walking around helping those that need assistance (we’ll do most/all soldering beforehand)

e Run the test script / troubleshoot

¢ Go through the code and show how to customize the script (maybe demo something that you
have made)

e Time for individual work / creativity

e If there is time; show and tell

Materials

Material Quantity|Cost |Supplier |Alt. Supplier
Arduino Nano v3 $3.40 |AliExpress|Tronixlabs $9

Adafruit 8x8 LED Matrix 1.2“ w/ Backpack , AliExpress, $2.10 Not
and 12C $18-$23|Tronixlabs tested

Female-female jumper wires $0.20 |Tronixlabs|AliExpress
Lithium lon Polymer Battery - 3.7v 500mAh $15 Tronixlabs|AliExpress, $5.70
Micro USB LiPo charger w/ Protection $4 Tronixlabs|AliExpress, $0.45
Case $4 In-house
Attachment / Clip / Lanyard $0.22 |AliExpress
Short USB Cable - USB-A to Micro USB $2 Tronixlabs|AliExpress, $0.80
TOTAL:|$51.50
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Tools & Equipment

e Solder Kit
e Computer

Instructions

Step Zero: Attaching LED Matrix to Backpack

Text on LED Matrix facing towards you

Backpack has a single filled circle, face it towards you (Adafruit logo on your right, filled circle
left)

Insert Matrix into backpack and flip it over

Make sure that LED Matrix text is on the same side as the “From Adafruit” text on the backpack
Solder the 16 points and clip off the legs at the base
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https://www.aliexpress.com/item/1PCS-Nano-3-0-controller-compatible-with-nano-CH340-USB-driver-NO-CABLE-NANO-V3-0/32684621397.html?spm=2114.search0104.3.25.XKpv3c&ws_ab_test=searchweb0_0,searchweb201602_5_10152_10065_10151_10130_5490020_10068_5460017_5560011_10307_10137_10060_10131_10155_10132_10133_10154_10056_10055_10054_10059_5470020_100031_10099_10338_10339_10103_10102_440_10052_10053_10107_10050_10142_10051_10326_10084_10083_10080_10082_10081_10110_10175_10111_10112_10113_10114_5380017_143_5570011_10312_10313_10314_10078_10079_10073_5550011,searchweb201603_21,ppcSwitch_5&btsid=0e3ed4e9-d27b-4515-8735-8176df71ac0f&algo_expid=5efb8802-b672-4d2f-b066-1515d3feecbd-3&algo_pvid=5efb8802-b672-4d2f-b066-1515d3feecbd
https://tronixlabs.com.au/arduino/boards/nano/arduino-nano-v3-0-compatible-australia
https://tronixlabs.com.au/display/led/matrix/adafruit-small-1-2-8x8-led-matrix-w-i2c-backpack-yellow-green-australia/
https://www.aliexpress.com/item/Free-shipping-MAX7219-dot-matrix-module-microcontroller-module-for-arduino-display-module-finished-goods/32305941397.html?spm=2114.search0104.3.1.dPNdMM&ws_ab_test=searchweb0_0,searchweb201602_5_10152_10065_10151_5490020_10130_10068_5560017_10307_10137_10060_10131_10155_10132_10133_10154_10056_10055_10054_10059_5470020_100031_10099_5460020_10338_10339_10103_10102_440_10052_10053_10107_10050_10142_10051_5380020_10326_10084_10083_10080_10082_10081_10110_10175_10111_10112_10113_10114_143_10312_10313_10314_10078_10079_5570017_10073_5550011,searchweb201603_21,ppcSwitch_5&btsid=34868971-667f-4b05-b767-36586f8723d9&algo_expid=1c70adbe-d66a-4ab6-9ca7-726b8e101ea9-0&algo_pvid=1c70adbe-d66a-4ab6-9ca7-726b8e101ea9
https://www.aliexpress.com/item/Free-shipping-MAX7219-dot-matrix-module-microcontroller-module-for-arduino-display-module-finished-goods/32305941397.html?spm=2114.search0104.3.1.dPNdMM&ws_ab_test=searchweb0_0,searchweb201602_5_10152_10065_10151_5490020_10130_10068_5560017_10307_10137_10060_10131_10155_10132_10133_10154_10056_10055_10054_10059_5470020_100031_10099_5460020_10338_10339_10103_10102_440_10052_10053_10107_10050_10142_10051_5380020_10326_10084_10083_10080_10082_10081_10110_10175_10111_10112_10113_10114_143_10312_10313_10314_10078_10079_5570017_10073_5550011,searchweb201603_21,ppcSwitch_5&btsid=34868971-667f-4b05-b767-36586f8723d9&algo_expid=1c70adbe-d66a-4ab6-9ca7-726b8e101ea9-0&algo_pvid=1c70adbe-d66a-4ab6-9ca7-726b8e101ea9
https://tronixlabs.com.au/display/led/matrix/adafruit-small-1-2-8x8-led-matrix-w-i2c-backpack-yellow-green-australia/
https://www.aliexpress.com/w/wholesale-jumper-wire-female-to-female.html?spm=2114.search0104.0.0.b2ghUX&initiative_id=AS_20170913194852&site=glo&SortType=total_tranpro_desc&g=y&SearchText=jumper+wire+female+to+female&CatId=400103
https://tronixlabs.com.au/power/battery/lipo/adafruit-lithium-ion-polymer-battery-3-7v-500mah-australia/
https://www.aliexpress.com/item/10pcs-3-7V-450mah-503035-Lithium-Polymer-Li-Po-Rechargeable-Battery-For-DIY-Mp3-MP4-MP5/1119097554.html?spm=2114.search0104.3.1.pvjsLA&ws_ab_test=searchweb0_0,searchweb201602_5_10152_10065_10151_10130_5490020_10068_5560011_10307_10137_10060_10131_10155_10132_10133_10154_10056_10055_10054_10059_5470020_100031_10099_5460020_10338_10339_10103_10102_440_10052_10053_10107_10050_10142_10051_5380020_10326_10084_10083_10080_10082_10081_10110_10175_10111_10112_10113_10114_143_10312_10313_10314_10078_10079_5570017_10073_5550011,searchweb201603_21,ppcSwitch_5&btsid=59c8d98a-40c7-4eb5-99ce-80b98de46e87&algo_expid=6ec27088-2b2b-48b6-906e-3b62a83c8a3d-0&algo_pvid=6ec27088-2b2b-48b6-906e-3b62a83c8a3d
https://tronixlabs.com.au/power/battery/charger/tp4056-single-lipo-cell-charger-with-protection-australia/
https://www.aliexpress.com/item/1PCS-5V-1A-Micro-USB-18650-Lithium-Battery-Charging-Board-Charger-Module-Protection-Dual-Functions/32467578996.html?spm=2114.search0104.3.1.p1HOkm&ws_ab_test=searchweb0_0,searchweb201602_5_10152_10065_10151_5490020_10130_10068_5560017_10307_10137_10060_10131_10155_10132_10133_10154_10056_10055_10054_10059_5470020_100031_10099_5460020_10338_10339_10103_10102_440_10052_10053_10107_10050_10142_10051_5380020_10326_10084_10083_10080_10082_10081_10110_10175_10111_10112_10113_10114_143_10312_10313_10314_10078_10079_5570017_10073_5550011,searchweb201603_21,ppcSwitch_5&btsid=4dfab8a1-317b-423b-9944-cccc0979065c&algo_expid=57072b0f-fd87-4756-b2a0-4dcf18ac62f0-0&algo_pvid=57072b0f-fd87-4756-b2a0-4dcf18ac62f0
https://www.aliexpress.com/item/10x-Lanyards-Neck-Strap-For-ID-Pass-Card-Badge-Gym-Key-Mobile-Phone-USB-Holder-DIY/32645496284.html?spm=2114.search0104.3.1.eLYUC7&ws_ab_test=searchweb0_0,searchweb201602_5_5570020_10152_10065_10151_10130_5490020_10068_10307_10137_10060_10131_10155_10132_10133_10154_10056_10055_10054_10059_5470020_100031_10099_5460020_10338_10339_10103_10102_440_10052_10053_10107_10050_10142_10051_5380020_10326_10084_10083_10080_10082_10081_10110_10175_10111_10112_10113_10114_143_10312_10313_10314_5560020_10078_10079_10073_5550011,searchweb201603_21,ppcSwitch_5&btsid=555bc41f-f88a-48a6-b281-aa5a7fd2dc05&algo_expid=b799df00-4c2b-4e8c-bf7f-20a3603dcee5-0&algo_pvid=b799df00-4c2b-4e8c-bf7f-20a3603dcee5
https://tronixlabs.com.au/cables/usb/short-usb-cable-a-plug-to-micro-usb-plug-10cm-australia/
https://www.aliexpress.com/item/USB-A-male-to-Micro-USB-male-Standard-Micro-USB-cable-data-charging-cable-short-30cm/32814091113.html?spm=2114.search0104.3.3.PCJvtK&ws_ab_test=searchweb0_0,searchweb201602_5_10152_10065_10151_5490020_10130_10068_5560017_10307_10137_10060_10131_10155_10132_10133_10154_10056_10055_10054_10059_5470020_100031_10099_5460020_10338_10339_10103_10102_440_10052_10053_10107_10050_10142_10051_5380020_10326_10084_10083_10080_10082_10081_10110_10175_10111_10112_10113_10114_143_10312_10313_10314_10078_10079_5570017_10073_5550011,searchweb201603_21,ppcSwitch_5&btsid=95df6b37-a5e8-4a32-bfc2-9700d365aef7&algo_expid=e0666954-f294-44c9-8cba-09922fa21aea-0&algo_pvid=e0666954-f294-44c9-8cba-09922fa21aea

SLQ Wiki 4/7 Wearables 2

e Use for header pins and set them into a breadboard with the long pins down
e Put the Matrix and backpack's 4 holes over the pins with the screen facing up
¢ Solder the pins, do not clip anything off

Step One: Arduino Software and Drivers

If you are using a genuine Arduino with the FT chipsets you won't need to download any drivers on PC
and MacOS Sierra or later. If you are using a knockoff Arduino with the CH340G chip you will need to
download the drivers for Mac.

Download the latest version of the Arduino IDE. Select your operating system and when prompted
choose “Just Download”.

Follow the instruction and install the program on your computer.

Step Two: Connecting and Testing the Arduino Nano

Connect the USB cable to your Arduino. A red and then a green light should light up on the Arduino,
indicating that it's receiving power. The green LED should glow solid. Now launch Arduino.

[l Tools JLUTS
| Auto Format 8T
Archive Sketch
I Fix Encoding & Reload
Serial Monitor 4 EM
X gerial Plotter 4L

“4 WIFi101 Firmware Updater

< Board: "Arduino Nano" 3
< Processor: "ATmega328" >
Port: "jdevjcuwchusbserial1410" >

§ Get Board Info

Programmer: "AVRISP mkll" -
uE
¢ Burn Bootloader
nrintlal"Rx® TFD Matrix Test™Y:

Go to the Tools menu and change the following:

e Board to Arduino Nano
e Processor to ATmega328
e Port to USB/Serial (different depending on OS and Chip)
o If you're having problems finding a USB port you most likely need to download the correct
drivers. Once again exact OS (and version) as well as the chip make a big difference.

Once that is done, run “Get Board Info” in the same menu, this should bring up a small popup with
some info. As long a you're not receiving an error in the console, you have successfully connected
your Arduino!
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https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver
https://www.arduino.cc/en/Main/Software
https://wiki.slq.qld.gov.au/lib/exe/detail.php?id=workshops%3Aprototypes%3Awearables%3Astart&media=workshops:prototypes:2022-23delivery-lasercutcovers:wearables:wearables_arduino_tools_menu.png
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Another step you can take to test that everything is working is load one of the basic example projects
and uploading it to the Arduino.

Go to File » Examples — 01.Basic - Blink

Click on the verify button (Check mark) and let it compile. You should be getting message at the top
of the console telling you when it's done (should take no more than a few seconds).

Once that is done, without any errors, click the Upload button (Arrow). This will upload the instructions
to the Arduino and it will say “Done Uploading” when everything worked.

Your red LED on the Nano should now be blinking, one second on, one second off. Uploading scripts to
your Arduino works! Now we are ready for the real projects.

Step Three: Downloading and Installing Libraries

In order to make the LED display a /ot easier to work with we'll need a couple of libraries that need to
be installed on the computer. Luckily there is a Libraries manager so we don't need to bother with
downloading, uncompressing and finding the correct directory.

Go to Sketch - Include Library -» Manage Libraries

Search for “Adafruit LED Backpack”, click on the Result and then click the “Install” button. Now search
for “Adafruit GFX Library” and install that one too. You will need to restart Arduino (by closing the
program not just the window).

You can also download and manually install the libraries: * LED Backpack Library * Adafruit GFX
Library

Once everything is installed launch Arduino again, it should now have the libraries installed and ready
to use.

Go to File » Examples again, at the bottom you should find “Adafruit LED Backpack Library”, within
that menu select “Matrix8x8".

This should open up a new Arduino window with a test project. Once you've completed Step Four:
Connect the LED Backpack you can upload this script to try it out.

Step Four: Connect the LED Backpack

There needs to be photos or graphics in here showing which pin is which as a visual guide

We're going to connect four wires to the arduino, two for power and ground and two for data and
system clock. Please note that the pins for SCL and SDA are different for each Arduino. Make sure you
google if you are using a different Arduino than in these instructions.

Arduino Nano:
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https://github.com/adafruit/Adafruit_LED_Backpack
https://github.com/adafruit/Adafruit-GFX-Library
https://github.com/adafruit/Adafruit-GFX-Library
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e SCL (System Clock) = A5
e SDA (System Data) -» A4
e GND (Ground) - GND

e VCC (Voltage In) » +5V

CheapDuino:

e SCL (System Clock) = A5
e SDA (System Data) -» A4
e GND (Ground) -» GND

e VCC (Voltage In) -» 3-5V

If you've completed the steps in step 3 you are now ready to upload your script.

Step Five: Troubleshooting

Production notes

Critical Success Factors

Which of the critical success factors does this Prototype target? For more details see
SLQ-Strategic-Plan-2016-20

Enable Access

e [ Provide life skills and early childhood literacy programs
e [ Increase free access to digital content
e [ Strengthen Queensland library infrastructure and discovery platforms

Engage Community

e [0 Grow the State’s historical collection of Queensland culture and heritage
e [ Engage with communities of interest through dedicated centres of engagement
e [ Facilitate the community’s use of and interaction with content

Build Capability

e [ Build capacity within our communities of interest
¢ [ Generate new revenue sources
¢ [ Position our workforce for the future
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https://wiki.slq.qld.gov.au/lib/exe/fetch.php?media=workshops:prototypes:2022-23delivery-lasercutcovers:slq-strategic-plan-2016-20.pdf
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Delivering of The Edge Promises

Aside from the SLQ Strategic Plan, there is The Edge's commitments to the community and the lens
we look at it through. Here are a few more check boxes for you to answer

This empowers creative experimentation across...

X [v phil, 2017-06-08]Art?

O Science?

X [v phil, 2017-06-08]Technology?
O Enterprise?

It will inspire...

X [v phil, 2017-06-08]Whimsy?
O Nostalgia?

X [v phil, 2017-06-08]Curiosity?
X [v phil, 2017-06-08]Awe?

Feedback

1. Feedback:
Solution:
2. Feedback:
Solution:
3. Feedback:
Solution:

4. Other observations:

References

e Adafruit LED Backpack 1.2 8x8 Matrix

Files

This is where you put files for laser cutting etc..
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https://learn.adafruit.com/adafruit-led-backpack/1-2-8x8-matrix
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